No estas registrado.

#1 2015-08-16 22:33:50

El_Aprendedor
Tuxes
Registrado: 2015-06-04
Mensajes: 50

[Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

No tengo audio en Debian 8 con KDE, la salida de audio es mi GTX 460.

Configure bien el audio graficamente en KDE, pero sigió sin oirse, luego instalé los drivers privados de nvidia, todavía no se oye nada, leyende en internet modifique un archivo de pulse audio, inutil, desinstale pulseaudio e instale alsa, seguía igual, configuro la salida de audio en el VLC y va genial pero solo es VLC necesito audio en todo el sistema operativo.

VLC me esta funcionando con alsa pero manualmente no con la configuración de alsa.

Si necesitan algun tipo de información adicional me la piden.

Desconectado

#2 2015-08-20 12:50:16

Tesla
Tuxes
Registrado: 2013-02-20
Mensajes: 147

Re: [Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

Dices que has configurado el audio gráficamente. Lo has hecho con kMix? Quizá debas cambiarle el canal maestro. A mi por defecto en Xfce me pone un canal en el que no sale audio. Simplemente es buscar esa opción en kMix y ver si hay otros canales maestros.

Ya nos cuentas.

Desconectado

#3 2015-08-20 23:15:00

El_Aprendedor
Tuxes
Registrado: 2015-06-04
Mensajes: 50

Re: [Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

No, lo hice en multimedia, en las configuraciones de KDE e hice el test en todas las partes posibles y no daba audio pero ahora que preguntas voy y entro para decirte donde fue, le doy al boton del test por que si y suena, luego voy a youtube y suena.

Ahora que mencionaste a Kmix acabo de hacer click derecho en el icono de volumen (no se como no se me ocurrio) y dice "Select Master Channel..." doy click y esta selecionada la salida que no es, aun así ahora hay audio pero selecione la salida correcta por si acaso.

Seguramente se habían peliado estos dos programas y Kmix salio ganando pero luego vino multimedia y rompio a Kmix, o solo era algun error de KDE.

Yo reiniciando en otro sistema y tenía la solución a un click de distancia.

Desconectado

#4 2015-08-21 12:19:23

El_Aprendedor
Tuxes
Registrado: 2015-06-04
Mensajes: 50

Re: [Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

Hoy prendo mi computadora y estoy sin audio otra vez, no he hecho ningun cambio, no se que paso, la unica diferencia que noto es que cuanda voy a multimedia solo puedo configurar PulseAudio Sound Server como predeterminado y ayer estaba mi tarjeta de video y la del audio interno (intel), nada de PulseAudio Sound Server.

Desconectado

#5 2015-08-21 22:24:00

El_Aprendedor
Tuxes
Registrado: 2015-06-04
Mensajes: 50

Re: [Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

He purgado pulseaudio pero sigue ahí, en multimedia, esto no puede ser posible. Help me!!! help me please!!!

Desconectado

#6 2015-08-24 02:06:09

YukiteruAmano
SystemInside Staff
Desde: /home/yukiteru
Registrado: 2013-05-12
Mensajes: 1,049
Página Web

Re: [Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

El_Aprendedor escribió:

He purgado pulseaudio pero sigue ahí, en multimedia, esto no puede ser posible. Help me!!! help me please!!!

Purgar pulseaudio no es una solucion, es aumentar el problema.

Pulseaudio se instala de forma predeterminada en el sistema porque permite hacer precisamente eso que deseas, tener multiples salidas de audio en un PC, sin que existan mayores problemas.

Con alsa puro, puedes hacerlo también, pero es mucho más problematico y rebuscado. Tu problema de falla de audio en Debian 8 KDE + Pulseaudio, se debe a que la configuracion de pulseaudio debe ser "adapatada" a tus requerimientos, es decir, debes activar la salida de audio HDMI en pulseaudio usando un sink.

Primero ejecuta este comando:

aplay -l

De alli te saldran una serie de entradas y salidas de audio que debes ir probando una a una, hasta conseguir la que requieres (tu HDMI Nvidia), para hacer esto, puedes usar este comando de referencia en el que la HDMI esta en la card:1 device:3

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Right.wav

Si consigues sonido con dicho comando, entonces has hallado la salida de audio que buscas activar, sino prueba con otra. Fijate que el archivio de sonido  /usr/share/sounds/alsa/Front_Right.wav, es completamente referencial, si este no existe puedes intentar reproducir otro que este en tu sistema.

Una vez que has localizado la salida, solo toca hacer:

nano /etc/pulse/default.pa

Y buscar la linea load-module module-alsa-sink

La editaras con el siguiente contenido:

load-module module-alsa-sink device=hw:1,3

Guardas los cambios del archivo, y reinicias pulseaudio con los comando:

pulseaudio -k
pulseaudio --start

Más informacion del tema aca


Dios en su Cielo, todo bien en la Tierra / God in his Heaven, all right in the Earth.

Desconectado

#7 2015-08-26 21:42:57

El_Aprendedor
Tuxes
Registrado: 2015-06-04
Mensajes: 50

Re: [Ayuda] Configurar alsa o hacer funcionar pulseaudio en Debian 8

Lo probare cuando inicie sin audio, aveces hay audio y aveces no.

Ahora mismo estoy pensando que talvez no sea problema de pulseaudio, ya que me di cuenta de que viene acompañado de otros sintomas. He instalado Cairo Dock y cuando la PC inicia sin audio tampoco inica Cairo, no se puede apagar el sistema operativo cuando no hay audio, tengo que ir a la tty. Al principio pensaba que estos problemas eran cosas aparte, pero me di cuenta que, o todo funciona bien o todo funciona mal.

Desconectado

Pie de página

Powered by FluxBB