No estas registrado.

#1 2014-07-29 19:10:58

arkhan
Tuxes
Registrado: 2013-08-14
Mensajes: 8

[Resuelto] Urxvt no muestra caracteres especiales

Un saludo voy menos de una seman con funtoo y la verdad estoy maravillado con esta distribucion, pero tengo un problema la terminal no me muestra los caracteres especiales que tengo configurados en el prompt de zsh para git:

# Default values for the appearance of the prompt. Configure at will.
ZSH_THEME_GIT_PROMPT_PREFIX=" "
ZSH_THEME_GIT_PROMPT_SUFFIX=" "
ZSH_THEME_GIT_PROMPT_SEPARATOR="|"
ZSH_THEME_GIT_PROMPT_BRANCH="%{$fg_bold[magenta]%}"
ZSH_THEME_GIT_PROMPT_STAGED="%{$fg[red]%}●"
ZSH_THEME_GIT_PROMPT_CONFLICTS="%{$fg[red]%}✖"
ZSH_THEME_GIT_PROMPT_CHANGED="%{$fg[blue]%}✚"
ZSH_THEME_GIT_PROMPT_REMOTE=""
ZSH_THEME_GIT_PROMPT_UNTRACKED="…"
ZSH_THEME_GIT_PROMPT_CLEAN="%{$fg_bold[green]%}✔"

URXVT

si se fijan en la imagen que esta en el enlace pueden ver que en el prompt derecho no aparece el simbolo "✔" sino un rectangulo
estos son lo USE FLAGS con los que compile urxvt

x11-terms/rxvt-unicode focused-urgency font-styles mousewheel perl -vanilla 256-color alt-font-width blink buffer-on-clear fading-colors iso14755 pixbuf secondary-wheel startup-notification unicode3 wcwidth xft

Ultima edición por arkhan (2014-08-05 21:08:45)

Desconectado

#2 2014-08-01 21:25:43

x11tete11x
SystemInside Staff
Desde: :(){ :|:& };:
Registrado: 2013-07-22
Mensajes: 253

Re: [Resuelto] Urxvt no muestra caracteres especiales

que tenes en el locale.gen? :v

Desconectado

#3 2014-08-02 10:56:11

arkhan
Tuxes
Registrado: 2013-08-14
Mensajes: 8

Re: [Resuelto] Urxvt no muestra caracteres especiales

# /etc/locale.gen: list all of the locales you want to have on your system
#
# The format of each line:
# <locale> <charmap>
#
# Where <locale> is a locale located in /usr/share/i18n/locales/ and
# where <charmap> is a charmap located in /usr/share/i18n/charmaps/.
#
# All blank lines and lines starting with # are ignored.
#
# For the default list of supported combinations, see the file:
# /usr/share/i18n/SUPPORTED
#
# Whenever glibc is emerged, the locales listed here will be automatically
# rebuilt for you.  After updating this file, you can simply run `locale-gen`
# yourself instead of re-emerging glibc.

es_EC.UTF-8 UTF-8
es_EC ISO-8859-1

Desconectado

#4 2014-08-04 02:21:35

world
♔ Royal Wheel
Desde: The Forbidden land of Gentoo
Registrado: 2014-03-16
Mensajes: 21

Re: [Resuelto] Urxvt no muestra caracteres especiales

Revisa tus locales, diría que Funtoo no está usando correctamete los locales:
Ya leíste este artículo de la wiki?
http://wiki.gentoo.org/wiki/Localizatio … C3.ADficas


l1mcwcw.png http://www.youtube.com/watch?v=F_yjgbXLcPM
¿Te gusta este lugar?
A mi realmente me gusta mucho, pero, nada puede permanecer como está para siempre; momentos felices, momentos tristes, es inevitable que todo eso cambie. Aun asi ¿puede seguir gustandote este lugar? Linux user #550818 (Amulet_Linux)

Desconectado

#5 2014-08-04 02:22:40

world
♔ Royal Wheel
Desde: The Forbidden land of Gentoo
Registrado: 2014-03-16
Mensajes: 21

Re: [Resuelto] Urxvt no muestra caracteres especiales

Sobre todo lo que nos interesa es que use un locale con UTF8


l1mcwcw.png http://www.youtube.com/watch?v=F_yjgbXLcPM
¿Te gusta este lugar?
A mi realmente me gusta mucho, pero, nada puede permanecer como está para siempre; momentos felices, momentos tristes, es inevitable que todo eso cambie. Aun asi ¿puede seguir gustandote este lugar? Linux user #550818 (Amulet_Linux)

Desconectado

#6 2014-08-04 08:56:03

x11tete11x
SystemInside Staff
Desde: :(){ :|:& };:
Registrado: 2013-07-22
Mensajes: 253

Re: [Resuelto] Urxvt no muestra caracteres especiales

no tengo mucha idea de por donde puede ir el problema, pero agregale los de ingles:
en_US.UTF-8 y el otro que no recuerdo, regenera con locale-gen
y acordate de tener bien configurado el /etc/env.d/02locale

Desconectado

#7 2014-08-04 13:35:44

arkhan
Tuxes
Registrado: 2013-08-14
Mensajes: 8

Re: [Resuelto] Urxvt no muestra caracteres especiales

ya lo leí, también probé añadiendo mas idiomas en locale.gen pero sigue igual

Desconectado

#8 2014-08-04 21:49:25

arkhan
Tuxes
Registrado: 2013-08-14
Mensajes: 8

Re: [Resuelto] Urxvt no muestra caracteres especiales

hice esta prueba con los siguientes caracteres:

✿ ☺ ☻ ☹ ☼ ☂ ☃ ⌇ ⚛ ⌨ ✆ ☎  ⌘ ⌥ ⇧ ↩ ✞ ✡ ☭ ← → ↑ ↓ ➫ ⬇ ⬆ ☜ ☞ ☝ ☟ ✍ ✎ ✌ ☮ ✔ ★ ☆ ♺ ⚑ ⚐ ✉ ✄ ⌲ ✈ ♦ ♣ ♠ ♥ ❤ ♡ ♪ ♩ ♫ ♬ ♯ ♀ ♂ ⚥ ⚢ ⚣ ❑ ❒ ◈ ◐ ◑ ✖ ∞ « » ‹ › “ ” ‘ ’ „ ‚ – — | ⁄ \ [ ] { } § ¶ ¡ ¿ ‽ ⁂ ※ ± × ~ ≈ ÷ ≠ π † ‡ ¥ € $ ¢ £ ß © ® @ ™ ° ‰ … · • ●

y obtuve el mismo resultado

Screen Shoot

Esta es la configuración de fuentes y localización que tengo actualmente:

eselect fontconfig list

Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf *
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf *
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf *
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf *
  [12]  20-unhint-small-dejavu-sans-mono.conf
  [13]  20-unhint-small-dejavu-sans.conf
  [14]  20-unhint-small-dejavu-serif.conf
  [15]  20-unhint-small-vera.conf *
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  40-nonlatin.conf *
  [20]  42-luxi-mono.conf *
  [21]  45-latin.conf *
  [22]  49-sansserif.conf *
  [23]  50-user.conf
  [24]  51-local.conf *
  [25]  52-infinality.conf *
  [26]  57-dejavu-sans-mono.conf
  [27]  57-dejavu-sans.conf
  [28]  57-dejavu-serif.conf
  [29]  59-google-droid-sans-mono.conf
  [30]  59-google-droid-sans.conf
  [31]  59-google-droid-serif.conf
  [32]  60-latin.conf *
  [33]  60-liberation.conf *
  [34]  62-croscore-arimo.conf
  [35]  62-croscore-cousine.conf
  [36]  62-croscore-symbolneu.conf
  [37]  62-croscore-tinos.conf
  [38]  65-fonts-persian.conf *
  [39]  65-khmer.conf
  [40]  65-nonlatin.conf *
  [41]  69-unifont.conf *
  [42]  70-no-bitmaps.conf
  [43]  70-yes-bitmaps.conf
  [44]  80-delicious.conf *
  [45]  90-synthetic.conf *


eselect lcdfilter list
Available styles:
  [1]   custom
  [2]   default
  [3]   infinality
  [4]   infinality-classic
  [5]   infinality-nudge
  [6]   infinality-push
  [7]   infinality-sharpened
  [8]   infinality-shove
  [9]   ipad
  [10]  linux
  [11]  nyx
  [12]  osx
  [13]  ubuntu
  [14]  vanilla
  [15]  windows-7 *
  [16]  windows-7-light
  [17]  windows-xp
  [18]  windows-xp-light


eselect infinality list
Available styles:
  [1]   debug
  [2]   infinality
  [3]   linux
  [4]   nyx
  [5]   osx
  [6]   osx2
  [7]   win7 *
  [8]   win98
  [9]   winxp

eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   es_EC
  [4]   es_EC.iso88591
  [5]   es_EC.utf8 *
  [ ]   (free form)

Desconectado

#9 2014-08-05 10:15:10

x11tete11x
SystemInside Staff
Desde: :(){ :|:& };:
Registrado: 2013-07-22
Mensajes: 253

Re: [Resuelto] Urxvt no muestra caracteres especiales

sad me quede sin ideas, vas a tener que esperar a alguien mas xD

Desconectado

#10 2014-08-05 11:01:01

arkhan
Tuxes
Registrado: 2013-08-14
Mensajes: 8

Re: [Resuelto] Urxvt no muestra caracteres especiales

no hay problema, ya plantee mi duda en los foros de Funtoo y Gentoo, si doy can la solución igual la posteo aquí

Desconectado

#11 2014-08-05 21:06:08

arkhan
Tuxes
Registrado: 2013-08-14
Mensajes: 8

Re: [Resuelto] Urxvt no muestra caracteres especiales

Miren esta esta fue la solución que me dio resultado
[Solved]Urxvt + UFT-8

Ultima edición por arkhan (2014-08-05 21:06:56)

Desconectado

#12 2014-08-05 22:19:18

eliotime3000
Vampiro hechicero | viajero interdimensional
Desde: Lima, Perú
Registrado: 2013-04-12
Mensajes: 700
Página Web

Re: [Resuelto] Urxvt no muestra caracteres especiales

arkhan escribió:

Miren esta esta fue la solución que me dio resultado
[Solved]Urxvt + UFT-8

Buena. Lo tomaré en cuenta para cuando corrija el error de caracteres que me da Debian al ver páginas en coreano.


eliotime™ ya está aquí. Para más información acerca del proyecto de eliotime™, visite http://eliotime.blogspot.com/

Desconectado

#13 2014-08-14 14:56:26

Berbellon
Tuxes
Registrado: 2012-09-30
Mensajes: 76

Re: [Resuelto] Urxvt no muestra caracteres especiales

eliotime3000 escribió:
arkhan escribió:

Miren esta esta fue la solución que me dio resultado
[Solved]Urxvt + UFT-8

Buena. Lo tomaré en cuenta para cuando corrija el error de caracteres que me da Debian al ver páginas en coreano.

¿? Yo no le veo ninguna relación a tu problema con el problema propuesto. Ni siquiera si trataras de ver páginas web con links o similares. Para que definir una fuente coreana para la terminal urxvt. O posiblemente no entendí, xD.

Sabía que el tipo de fuente era culpable, pero como soy un ignorante en Gentoo/Funtoo, no me atreví a comentar, la maldita duda ... Pensé que la cosa venía por acá:

https://forums.gentoo.org/viewtopic-t-8 … art-0.html

Y para futuras búsquedas:

https://wiki.archlinux.org/index.php/rx … on_methods

Bye!

Desconectado

#14 2014-08-14 15:01:45

Berbellon
Tuxes
Registrado: 2012-09-30
Mensajes: 76

Re: [Resuelto] Urxvt no muestra caracteres especiales

@arkhan

Yo no veo esta fuente "xft:Symbola:pixelsize=10", como disponible. ¿La instalaste despues?

Desconectado

Pie de página

Powered by FluxBB